Unity 2017.2.0f3 is the latest version ready for HoloLens development

31 December 2017

If you are a HoloLens developer I’d like to let you know that all versions above 2017.2.0f3, including 2017.3, have an issue with the stabilization plane, which leads to Holograms stuttering and jittering as well as the device loosing tracking of the environment. So your best bet right now is to not update until the issue is resolved.